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Copyright
The computed tomography software is available separately as Computed Tomography Pro (554 820) or as part of the
computed tomography module (554 821) from LD DIDACTIC GmbH. It is designed for instruction in schools and
universities.
The software is licensed by means of an activation code (554 820) or the computed tomography module (554 821).
You may not reveal your activation code to colleagues at other educational institutions.
However, the reconstruction or display of the recorded data sets may also be done without activation code and without the computed tomography module. For this purpose the software may be installed on any number of computers
and it may be redistributed as long as it remains unchanged.
It is not permitted to use the software for the reconstruction or display of data records recorded elsewhere or to decompile or disassemble the software of parts of the software.
LD DIDACTIC GmbH does not grant a guarantee for the correct functioning of the software. In particular, the values
and representations determined do not have any meaningfulness for medicine.
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Introduction
The purpose of this handbook is to give an overview of the facilities of the computed tomography software. Its text is
identical to the help which can at all times be called by a click of the mouse.

Safety information
The X-ray image sensor, the computed tomography module and the software are designed for education in schools
and universities. The values determined and representations do not have any meaningfulness for medicine.
The X-ray apparatus may only be operated in conformity with the operating instructions for the X-ray apparatus.

Installation
This installation is performed in two parts.
a) Installation of the computed tomography software
The software installation is done either



automatically after the CD-ROM is inserted or
manually by starting the setup.exe file

and by observing the instructions given on the screen.
If necessary, Microsoft .NET Framework 3.5 and DirectX Runtimes are installed during the software installation.
b) Installation of the USB video driver (only required for the computed tomography module)
The computed tomography module contains a USB video grabber for the conversion of the analogue video signal
from the camera. The video grabber requires the installation of a driver which is available on the CD in the Driver
subdirectory.
Depending on the installed video grabber, either an executable installation program (e.g. Driver\Setup.exe) or the
actual video driver (e.g. Video.inf) are found there.
In the first case the installation program (e.g. Driver\Setup.exe) has to be run before connecting the computed tomography module to the PC. In the second case Windows searches for the driver on the CD after connecting the computed tomography module to the PC and switching on.
If you wish to use a different video grabber, it can be connected to the analogue video output of the computed tomography module. Such video grabbers also require an installed driver which provides a DirectShow filter via which the
computed tomography software accesses the video data.
Important: Even when the internal video grabber is not being used, the computed tomography module must be connected to the computer via a USB cable.
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X-ray image sensor
The X-ray image sensor (554 828), consisting of a sensor head and USB module, is used for recording X-ray images
in the experimentation chamber of an X-ray apparatus (e.g. 554 800). In order to achieve this, the X-ray radiation is
transformed to visible light in the sensor head by means of a scintillator screen. Between this scintillator screen and
CMOS image sensor behind it, the remaining X-ray radiation is screened by a fibre optics system in order to ensure a
long service life for the image sensor. The analogue output signal from the sensor head is transmitted to the USB
module outside the X-ray apparatus via the DVI cable included. The digital X-ray image is created there for direct
transmission to the PC.
The separately available precision slide (554 829) serves to precisely position the X-ray image sensor in the X-ray
apparatus. Computed tomograms are recorded at the right-hand end of the rail. The centre of the image sensor can
be aligned there precisely on the rotational axis of the goniometer. The left-hand end of the rail is well-suited for the
production of digital Laue images.
The software Computed Tomography Pro (554 820) is used for the automatic recording, taking only a few minutes, of
projections of the X-rayed object as a function of the angle. During the recording, the back-projection process is visualised in either two or three dimensions. This means that cross-sections and 3D images of the unfinished 3D object
are available using all of the 3D viewing tools (rotate, zoom, transparency effects, sections, stereoscopic view, and
illumination similar to the Heidelberg ray tracing model). With every further angular step, the back-projection process
adds to the 3D object until it is finally complete.
Despite the low X-ray energy of 35 keV of a school X-ray device, highly resolved computed tomograms of various
objects can be recorded and evaluated qualitatively and quantitatively. The emphasis is on the didactic processing of
the recording process and the evaluation.
In addition to the software, the Package Computed Tomography Pro (554 820P) also includes the X-ray image sensor (554 828) and the precision slide (554 829). An appropriate X-ray apparatus and a high performance computer
are required in addition.

Technical data
Analogue sensor head
Sensor:
Sensor area:
Resolution:
Pixel size:
Video output:
Connection:
Housing:
Dimensions:
Mass:

CMOS without pixel line defects (Premium Grade)
49.2 mm x 48.0 mm (shielded for increased durability)
1024 pixel x 1000 pixel
48 µm x 48 µm
analogue (0.5 µV/electron)
Dual-Link DVI socket
Special steel
75 mm x 88 mm x 34 mm
500 g

Digitalising USB module
Resolution AD converter:
Read-out time:
Connection:
Dimensions:
Mass:

12 bit greyscale
approx. 3.3 s
USB 2.0 (full speed)
186 mm x 165 mm x 30 mm
700 g

Software
Control:
Number of projections:
Angular resolution:
Size of the computed tomogram:
Versions:

X-ray apparatus, goniometer, and image sensor over USB
1/4/15/45/90/180/360/720 images per computed tomogram
up to 0.5°
200 ... 940 pixels per dimension (8 ...830 megavoxels)
32 bit and 64 bit (for larger computed tomograms)

Accessories
Software Computed Tomography Pro (554 820)
Computed tomography accessory (554 826)
Rot-cyan glasses (554 827)
Precision slide X-ray image sensor (554 829)
Pinhole collimator with Laue crystals (554 8381)
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Minimum requirements for the computer using the X-ray image sensor
The real-time recording and evaluation of computed tomograms requires a large amount of processing on the processor and the graphics card. Despite the high degree of optimisation of the algorithms used, the minimum requirements below apply:







Windows XP SP3 or Windows Vista/7/8 (32 bit or 64 bit)
Dual-core processor 2.4 GHz
3 GB RAM
3D graphics card (Nvidia GT 630 / AMD HD 6670 or better)
2 x USB 2.0 port
DVD drive

For larger computed tomograms we recommend a higher computer performance:







Windows Vista/7/8 (64 bit)
Quad-core processor 3 GHz
8 GB RAM
3D graphics card with 2 GB RAM (Nvidia GTX 660 Ti / AMD HD 7870 or better)
2 x USB 2.0 port
DVD drive

Minimum requirements for the X-ray apparatus using the X-ray image sensor
The X-ray apparatus has to have a channel for the DVI cable to pass through, e.g. basic X-ray apparatus (554 800 or
554 81).
For the recording of computed tomograms, a goniometer and a USB port are also required, e.g. X-ray apparatus Mo
(554 801 or 554 811USB). The X-ray apparatus (554 81) with the serial interface cannot be used for computed tomography.
The X-ray tube used is responsible for the intensity of the images. We recommend the use of a W or Au tube.

X-ray apparatus firmware
The firmware for the X-ray apparatus has to be compatible with the computed tomography software:



for 554 801: version 1.03.A-2.2 or newer
for 554 811USB: version 3.03 or newer

The version is displayed in the settings.
The up-to-date firmware is contained in the X-ray apparatus program which can be downloaded from http://www.lddidactic.com/software/xrsetup.exe.

© by LD DIDACTIC GmbH · Leyboldstrasse 1 · D-50354 Huerth · www.ld-didactic.com
Phone: +49-2233-604-0 · Fax: +49-2233-604-222 · E-mail: info@ld-didactic.de · Technical alterations reserved

6

Computed Tomography

Computed tomography module
The computed tomography module (554 821) is used for the recording, within a few minutes, of projections of the Xray object as a function of the angle. During the recording, the included computed tomography software visualises the
back-projection process in either two or three dimensions. This means that cross-sections and 3D images of the unfinished 3D object are available using all of the 3D viewing tools (rotate, zoom, transparency effects, sections, stereoscopic view, and illumination similar to the Heidelberg ray tracing model). With every further angular step, the backprojection process adds to the 3D object until it is finally complete.
Despite the simple measuring method and the low X-ray energy of 35 keV of a school X-ray device, highly resolved
computed tomograms of various objects can be recorded and evaluated qualitatively and quantitatively. The emphasis is on the didactic processing of the recording and of the evaluation.
An appropriate X-ray apparatus and a high performance computer are required in addition.

Technical data
Attachment of the object:
Max. object size:
Object resolution:
Angular resolution:
Size of the computed tomogram:
Computer connection:
X-ray apparatus connection:
Separate video output:
Mains connection:
Dimensions (w x h x d):
Mass:

to the goniometer of the X-ray apparatus
approx. 8 x 8 x 8 cm³
approx. 0.25 mm
1 - 360 projections per tomogram
200 - 340 pixels per dimension
USB 2.0 port
USB 2.0 port
cinch (CCIR)
230 V, 50/60 Hz
53 cm x 34 cm x 24.5 cm
13.5 kg

Scope of delivery
1
1
1
1
1
1

computed tomography module including light sensitive b/w camera
computed tomography software for the control, recording, 3D view and evaluation
object (small dried animal, e.g. frog)
cuvette (e.g. for water)
object holder including expanded polystyrene holder and rubber rings
USB cable

Accessories
Lego adapter (554 825)
Computed tomography accessory (554 826)
Rot-cyan glasses (554 827)

Minimum requirements for the computer using the computed tomography module
The real-time recording and evaluation of computed tomograms requires a large amount of processing on the processor and the graphics card. Despite the high degree of optimisation of the algorithms used, the minimum requirements below apply:







Windows XP SP3 or Windows Vista/7/8 (32 bit or 64 bit)
Dual-core processor 2 GHz
2 GB RAM
3D graphics card (Nvidia GT 610 / AMD HD 6450 or better)
USB 2.0 port
DVD drive

For larger computed tomograms we recommend a higher computer performance:







Windows Vista/7/8 (64 bit)
Quad-core processor 2.4 GHz
4 GB RAM
3D graphics card (Nvidia GT 630 / AMD HD 6670 or better)
USB 2.0 port
DVD drive
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Minimum requirements for the X-ray apparatus using the computed tomography module
The X-ray apparatus must be compatible with the computed tomography module, e.g.:


X-ray apparatus Mo (554 801 or 554 811USB) including molybdenum tube and goniometer

The X-ray apparatus (554 81) with the serial interface cannot be used.
The X-ray tube used is responsible for the intensity of the images on the fluorescent screen. We recommend the use
of a tungsten tube:




basic device, X-ray apparatus (554 800)
goniometer (554 831)
X-ray tube W (tungsten tube, 554 864)

or



X-ray apparatus Mo (554 801) including goniometer
X-ray tube W (tungsten tube, 554 864)

X-ray apparatus firmware
The firmware for the X-ray apparatus must be compatible with the computed tomography module:



for 554 801: version 1.03.A-2.2 or newer
for 554 811USB: version 3.03 or newer

The version is displayed in the settings.
The up-to-date firmware is contained in the X-ray apparatus program which can be downloaded from http://www.lddidactic.com/software/xrsetup.exe.
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Computed tomography software
Introduction
In 1963 and 1964 Allan Cormack published in the Journal of Applied Physics the theoretical basis for computed tomography. In 1972 Godfrey Hounsfield built the first computed tomography apparatus and together with Allan
Cormach received for his work in computed tomography the Nobel price for physiology and medicine in 1979. The
basis of this computed tomography is to irradiate an object with X-rays from many different angles.
Even school X-ray apparatus can irradiate objects and make the resulting projections visible on a fluorescent screen.
These projections are not particularly bright. For this reason a very sensitive camera is required in order to record
them with a computer. The cameras supported are the X-ray image sensor (554 828) and the camera in the computed tomography module (554 821).
If an object is rotated with the integrated goniometer and for every angle step a projection is recorded, the computer
can reconstruct from this the irradiated object. The didactic computed tomography software illustrates the backprojection process required for the reconstruction step by step and in analogy to the scanning process, and finally
displays the complete 3D model. In contrast to the medical device, the X-ray source is not rotated but instead the
object to be investigated is rotated.
Despite the low X-ray energy of 35 keV, quite presentable and highly resolved computed tomograms of various objects can be recorded and evaluated qualitatively and quantitatively. The emphasis is on the didactic processing of
the recording and of the evaluation.

Activation code
An activation code is required for the operation of the software with the X-ray image sensor (554 828) as a computed
tomograph. This activation code is found on the delivery note for software 554 820 and consists of a name and a
code. Both pieces of information together activate the software at
Help → About ….
For the creation of Laue images or for the creation of computed tomograms with the computed tomography module
(554 821) no activation code is required.

First steps
Before recording the projections the X-radiation must be switched on, and the camera must be precisely adjusted in
parallel to and centred on the rotational axis:
Setting up of camera and X-ray device
During the recording of the projections from n different angles, the original distribution of the linear attenuation coefficient µ can be determined in the irradiated volume by a computer algorithm (filtered back-projection) and therefore
also µ(x,y,z) and the corresponding CT numbers:
Recording the projections and calculation of the back-projections (CT scan)
After the scan a number of visualisation options are available:
Projection video during one turn
Reconstruction video of the cutting planes xy, xz, zy
3D view and evaluation of the computed tomogram
3D video
The most important option is the 3D view and evaluation. In the 3D view all attenuation coefficients, CT numbers and
distances in the computed tomogram can be determined and displayed. An illumination similar to the Heidelberg
raytracing model makes the views more three-dimensional, and sections at any location allow fine structures to be
made visible.
Of course, the 3D data obtained in this way can also be saved and later reused:
Loading and saving of settings and 3D data
Ideas and step-by-step guidance for one's own experiments with the computed tomography apparatus can be found
in the instructions:
Examples of experiments
Step-by-step instructions
For further study of the basics and the algorithm used in computed tomography, we recommend:
A. Kak and M. Slaney, Principles of Computerized Tomographic Imaging, IEEE Press 1988,
http://www.slaney.org/pct/pct-toc.html.
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Adjusting of camera and X-ray apparatus
Go to the step-by-step instructions

View → Change Settings
Before recording the projections the X-ray image sensor or the camera in the computed tomography module and the
X-rays must be switched on and the camera must be precisely adjusted in parallel and centrally with respect to the
rotational axis.

Camera (open with

)

If during the software start-up a camera is found, it is automatically switched on (
briefly displayed.

flashes) and then its image is

In the camera setting an option for setting the video device is available. If the computed tomography module is connected to the computer the used video grabber from the computed tomography module will be found in the selection
list. This video grabber has an S-video input available to which the camera is connected. The video input can be
switched to composite video for the utilisation of external video grabbers.
The camera can be manually started and stopped with

and

.

Defective pixels
If the black camera image shows irritating light spots, these can be suppressed by means of a defective pixels list.
The same applies to individual, disruptive, dark spots when the X-ray radiation is switched on. The defective pixel list
is automatically filled by running Identify defective pixels using dark and/or white frame. The pixels in the lists are
then no longer measured but interpolated from their neighbouring pixels.

Offset
When the X-ray radiation is switched off, the X-ray image sensor will produce a weak offset image which can be calculated by the Create offset image using dark frames function. Here offset images are averaged while the button is
being pressed.
For making Laue images with the X-ray image sensor, first the offset has to be determined as it can be higher than
the actual Laue image.

Reference
The fluorescent screen is not completely illuminated when the X-radiation is switched on. The reference intensity (0%
attenuation) is normally the brightest spot of the fluorescent screen and the recorded projections are normalised to it.
By Create reference image for flat-field correction every point on the fluorescent screen is allocated its own reference intensity and the projections are thereafter illuminated uniformly. Here reference images are averaged while the
button is being pressed. Before the recording of the reference image, the object with its holder has to be removed
from the X-ray apparatus. The red square in the preview must be empty.
When making Laue images with the X-ray image sensor, the Laue image is determined as a reference measurement,
the intensity of which can be adjusted by means of the slide adjuster.

Notes on the X-ray image sensor
The integration time has to be adjusted, depending on the tube deployed, to 825 ms (for W tubes and Au tubes) or to
1750 ms (for Mo tubes and Ag tubes). The recording of the image, including the image transfer, always takes an
integral multiple of this integration time. Depending on the integration time, it is typically 3.3 s or 3.5 s.

Notes on the computed tomography module
On account of the relatively weak image on the fluorescent screen, the individual camera images contain a lot of
noise. For this reason several video frames have to be averaged before they can be used for the calculation of the
computed tomogram. As a standard, the average of 20 video frames is determined. In this way every image recorded
only requires just under a second. If a Mo or Ag X-ray tube is used, increase the number of frames to be averaged
because this tube produces considerably less X-radiation than the W or Au X-ray tube. At the external video output
the average of the images is not determined.

X-Rays (open with

)

When the X-ray apparatus is switched on, closed and connected to the computer, the X-rays can be switched on by
clicking
( flashes) and switched off by clicking .
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When the X-ray apparatus is switched on and connected to the computer its version is displayed and the recommended values of 35 kV for the high voltage and 1 mA for the anode current can be modified.
For the recalculation of the measured attenuation coefficient as CT numbers, the attenuation coefficient µ of water is
required. The default value is set and unfortunately it is not constant (see note). The CT numbers H are calculated
from the measured attenuation coefficient µ with
H = 1000 * (µ - µwater) / µwater.
Therefore air has the CT number H = -1000 HU (Hounsfield Units) and water has the CT number H = 0 HU.

Note
The default of 35 kV achieves a polychrome energy spectrum of the X-radiation reaching up to 35 keV depending on
the anode material deployed. The basis of the reconstruction algorithm used is the attenuation of the X-rays when
passing through material of thickness d with an attenuation coefficient µ:
I = I0 * e

-µd

.

However, the attenuation coefficient µ depends on energy. For this reason the equation applies only for monochromatic X-radiation. Higher energy X-radiation is usually attenuated less.
This effect is already observable if a container filled with water of varying thickness is irradiated. The more the water
attenuates the X-radiation the higher is the average energy of the X-radiation leaving it, because the lower energy
component is attenuated more than that of a higher energy. The water therefore makes the X-rays harder.
The measured attenuation coefficient µ is lower the more water is irradiated. In addition, the measured attenuation
coefficient depends on the anode material of the tube, on the thickness of the outlet window and the setting of the
high voltage.
In the software all these effects are not corrected for. For this reason the CT numbers displayed also depend e.g.
somewhat on the thickness of the irradiated material.

Image Adjustment and Calibration
The distortion correction (for the computed tomography module only) corrects the barrel-shaped distortion usually
observed for camera objectives with a short focal length. It is preset to 5%. This value can be checked and if necessary corrected by placing chequered paper in front of the opening of the computed tomography module.
The horizontal shift of the red wire cross is set in such a way that the wire cross is horizontally in the centre of the
fluorescent screen. If the shift is any larger, the installation of the camera in the computed tomography module must
be checked.
The vertical shift of the red wire cross from the centre of the rotational axis should remain at 0. It is recommended to
correct the shift with respect to the rotational axis by means of a correction of the rotational axis.
For the length calibration of the tomography apparatus, the size of the fluorescent screen (for the computed tomography module only) should be adjusted in such a way that the red circle exactly traces the limits of the depicted fluorescent screen. If this is not possible with precision, the vertical shift of the screen can be adjusted. The horizontal
shift has already been adjusted.
The distance of the screen from axis of rotation is also required for the length calibration of the tomograph. The
recommended distance of 40 mm (using the X-ray image sensor) or 80 mm (using the computed tomography module) corresponds to the goniometer shifted to the extreme position on the right-hand side.

Size of the Computed Tomogram
The fewer projections that are recorded and the smaller the reconstructions are, the more rapid the recording of a
computed tomogram. The reconstruction faults become larger as the number of projections decreases, and the reconstructed volume decreases with decreasing size.
The more projections that are recorded and the larger the reconstructions, the longer the recording of a computed
tomogram takes. The reconstruction faults become smaller with increasing number of projections, and the reconstructed volume become larger with increasing size of the reconstruction.
With the exception of didactically quite sensible experiments with a small number of projections normally a number of
projections of 180 or 360 angles are recommended.
The size of the projection should always be larger than the size of the reconstruction. The size of the projection is
displayed with the red square in the preview.
The size of the reconstruction should not be chosen to be larger than is absolutely necessary for the object under
investigation.
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Notes on the X-ray image sensor
Normally CTs are calculated with half the sensor resolution of 96 µm. This means that the projections have a maximum size of 500 x 500 pixels² and that the maximum sensible length of the edge of a computed tomogram of
460 pixels is approx. 4 cm in reality. The PC and the graphics card then process up to 100 megavoxels (100 million
volumetric pixels).
With particularly powerful computers, the full sensor resolution of 48 µm can be deployed by clicking Full resolution
(half edge length). In this way the maximum size of the projections is increased to 1000 x 1000 pixels². The edge
length of 460 pixels is then only approx. 2 cm, but can be increased to 940 pixels (corresponds to approx. 4 cm). This
increases the demands on the PC and the graphics card because then over 830 megavoxels have to be processed,
which can only be realised by means of a 64 bit operating system with 8 GB RAM and a high-performance graphics
card.
If the performance of the graphics card is not sufficient to render a new 3D image within 2 s, Windows will stop the
graphics driver and then re-start it. In this case please select the smaller reconstruction size or a more powerful
graphics card.

Reconstruction size
256 x 256 x 256 pixel³
340 x 340 x 340 pixel³
460 x 460 x 460 pixel³
512 x 512 x 512 pixel³
700 x 700 x 700 pixel³
940 x 940 x 940 pixel³

Full resolution
no
no
no
yes
yes
yes

Voxel resolution
86 µm
86 µm
86 µm
43 µm
43 µm
43 µm

Cube edge
2.2 cm
3 cm
4 cm
2.2 cm
3 cm
4 cm

File size
31 MB
150 MB
370 MB
512 MB
1.3 GB
3.2 GB

On account of the cone beam back-projection, the voxel resolution of the computed tomogram is somewhat better
than the sensor pixel resolution.

AVI Export (open with

)

The AVI export utilises the adjustable video compressor. Here all the installed DirectShow filters can be adjusted.
The specified speed defines the number of individual images which are to be played per second and therefore the
speed of the projection videos and the reconstruction videos.
The 3D video is restricted by the maximum settable recording time. The preset 20 s are sufficient for precisely one
turn with Effects → Animation around Axis of Rotation.
During an AVI export the required individual images are temporarily stored in the directory Frames\Projectname. If
the images are required for a different purpose, the subsequent deletion can be switched off here.
The format of exported videos or saved pictures during the stereoscopic view can be switched here between anaglyph and side-by-side (cross-eyed).
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Recording the projections and calculation of the back projections (CT scan)
Go to the step-by-step instructions
During and after the recording of a computed tomogram it can be displayed either as a

view or as a

view.

CT → Start CT Scan …
Once the camera and the X-rays are switched on and the camera has been adjusted, only the project name has to be
entered under which, after completion of the computed tomogram, the settings and the 3D data are to be saved.
During the recording of a computed tomogram all the scanned projections are automatically saved in the subdirectory Projections\Project name. This collection of images contains the data the calculation of the computed tomogram is based on and it allows retrospective recalculating of the computed tomogram.
If before the start an animation around the axis of rotation or the recording of a 3D video had been switched on, these
are reset. The animation starts again at 0° and the recording of the 3D video is restarted. In this way videos can be
exported which show the 3D back-projection process.

CT → Recalculate CT Scan
If a computed tomogram has already been loaded, it can then be recalculated. Then all options for the presentation
and visualisation are available as in the case of a real scan. This process is particularly useful if the record is to be
made without camera and without the X-ray apparatus, e.g. in order to become familiar with the program.
For the recalculation the subdirectory Projections\Projectname which was created during the original scan is required.
If before the start an animation around the axis of rotation or the recording of a 3D video had been switched on, these
are reset. The animation starts again at 0° and the recording of the 3D video is restarted. In this way videos can be
exported which show the 3D back-projection process.

CT → Pause and Resume CT Scan
During the recording of a computed tomogram the scan can be interrupted at any time and resumed.

CT → Stop CT Scan
The recording of a computed tomogram can be terminated at any time.
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2D view and correcting a computed tomogram
Go to the step-by-step instructions
During or after the scan or after loading a computed tomogram, it can be displayed and evaluated in two dimensions.

Effects → Colour Spectrum
5 different colour spectra are available. The more differentiated a colour spectrum is, the more likely it is that small
changes in the attenuation coefficient µ will be displayed in different colours. However, voxels which are close to the
edge of the object are usually not completely filled. You then have an average µ and this can lead to coloured edges.

Intensity (open with

)

During or after the scan, the intensity of the computed tomogram can be set in such a way that as many details as
possible but as few artefacts as possible will be visible.

View (open with

)

During the calculation of the computed tomogram, the right-hand diagram shows either:




the projections as they were recorded by the camera,
the logarithmic projections or
the filtered logarithmic projections as they are back-projected into the volume shown on the left hand side.

For the back-projection, the filtered and logarithmic projections are first scaled to the rotational axis and then they are
smoothed out along the beam cone. This can be illustrated by means of the displayed marks.
During or after the scan, the z-plane which is to be displayed in the back-projected volume can be adjusted by means
of the large slide bar at the lower window edge. The cone beam geometry means that for the back-projection only
one projection column is required for the middle plane. In outer areas, more are required. This is indicated by the
vertical red marks.

Correction (open with

)

After the scan, the rotational axis can be corrected to the set z-position (large slide bar). A false rotational axis leads
to double edges in the computed tomogram. These double edges can be prevented by a correction of the rotational
axis:






Carry out the correction of the axis of rotation for z = 25% (left-hand edge) and select 1st position. Afterwards,
the software will attempt to automatically optimise the image sharpness in the range ±3 pixels. If this is not successful, re-adjust manually and select 1st position once again.
Carry out a correction of the axis of rotation for z = 75% (right hand edge) and select 2nd position. Afterwards,
the software will attempt to automatically optimise the image sharpness in the range ±3 pixels. If this is not successful, re-adjust manually and select 2nd position once again.
Adjust the adjustment screws on the precision slide or the computed tomography module as shown in the illustration.
Repeat computed tomogram via
CT →Start CT scan.
After the second correction at the latest, no further correction of the rotational axis should be necessary.
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3D view and evaluation of the computed tomogram
During or after the scan or after loading a computed tomogram, it can be displayed and evaluated in three dimensions.

Actions → Show 3D View
The x-axis and the y-axis of the view are adjusted towards the upper right. The z-axis points out of the monitor and
together with the x-axis and the y-axis forms a so-called right-handed coordinate system.

Rotation
When the left mouse button is pressed the object is rotated around the x-axis and the y-axis as indicated by the
mouse movement. A rotation around the z-axis is only possible when the outer part of the screen area is clicked and
effectively rotated around the object.

Zooming
When the left mouse button is pressed, the object is zoomed as indicated by the mouse movement.

Effects → Reset Angle and Zoom
Resets the angle and the zoom setting to their start values.

Effects → Rotate by 90°
Rotates the displayed volume by 90°. This easily allows the starting view
direction of the x-ray source.

to be switched to a view pointing in the

Effects → Show Cutting Plane only (2D)
The mouse cross displayed always only moves in one two-dimensional plan (the z-plane). For this reason the coordinates shown in the upper right-hand corner always relate to this cutting plane.
This plane can be pushed forwards and backwards by means of the large slide bar at the bottom window edge. In the
3D view only those parts of the object are shown which are behind the cutting plane. The further the bar is shifted to
the right, the less of the object is therefore displayed. By selecting
, this view can be switched to a 2D view. Then
only the cutting plane itself will be displayed.
In this 2D view, the mouse cross, and therefore the coordinates displayed, correspond exactly to the part of the object shown below. In addition to the coordinates, the measured attenuation coefficient µ and the CT number H at this
position are also given. The CT number H is calculated from the attenuation coefficient µ:
H = 1000 * (µ - µwater) / µwater.
Therefore air has the CT number H = -1000 HU (Hounsfield Units) and water has the CT number H = 0 HU.
µwater can be set, but it also depends on the hardness of the X-radiation. As the software does not correct for this, the
CT number depends on the intensity of the X-radiation – e.g. on the thickness of the irradiated material.

Determination of Distances
After a single click with the left mouse button (i.e. without any movement when the mouse button is pressed) a red
distance marker appears with the length measurement as measured on the cutting plane. This mark is fixed by a
second click.
By means of the mouse wheel (coarse setting) or the cursor buttons (fine setting), the cutting plane can be changed
during the measurement of the distance. This also allows three-dimensional distances to be determined.

Intensity and Transparency
The measured 3D data are available as cubes consisting of many voxels (small cubes). Depending on the selected
resolution of the reconstruction, this can be as many as 830 million voxels. Every voxel corresponds to the attenuation coefficient µ of the irradiated volume in this position.
The voxels in the volume are displayed in a black histogram. At the left-hand side all voxels with µ = 0 /cm are displayed. Usually the beam reaches far out of the histogram at the top (air is the most common). The right-hand value
of the histogram depends on the intensity controller. The further the intensity controller, and therefore the distribution
in the histogram, is shifted to the right, the smaller is the µ shown on the right-hand side. The actual value for µ beneath the mouse pointer is shown in the upper-right-hand corner in the status display.
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Every position in the histogram, and therefore every voxel, is now allocated a colour value from the selectable colour
spectrum shown below. By means of the mouse, the colour spectrum can be restricted using the two white lines. If
e.g. cotton wool is used as a filler around the object, it can be hidden by slightly raising the left limit and in this way
the actual object is made more clearly visible.
For the view of the cutting plane (2D) and in the 2D view, the colour value determined for every voxel shown is actually displayed.
However, in the 3D view most of the voxels must be transparent because otherwise one would see only the mainly
black external surfaces of the cube. The degree of colour-dependent transparency is adjusted with the transparncy
controller, and it is illustrated by the red transparency curve. The further the transparency controller is shifted towards
the right, the more transparent the voxels become.

Effects → Colour Spectrum
5 different colour spectra are available. The more differentiated a colour spectrum is, the more likely it is that small
changes in the attenuation coefficient µ will be displayed in different colours. However, voxels which are close to the
edge of the object are usually not completely filled. You then have an average µ and this can lead to coloured edges.
If "Normal colour vision" is switched off, 3 colour spectra are selectable which are optimised for people with red-green
colour blindness.

Effects → Animation
Both animations (around the rotational axis and with the mouse) allow the 3D objects to rotate around an axis independently. This axis is either the rotational axis during the scan (z-axis of the object) or it is defined by rotating the
object with the mouse.
During the animation it is also possible to record what is shown on the screen and to export the 3D film as an AVI file.

Effects → Show Cube
For better orientation, the limits of the computed tomogram can be marked by the edges of the cube.

Effects → Switch Light On
Without light (only ambient light) the colours are determined and shown by the intensity and transparency controller.
For the illumination, two light sources are switched on, just as for the Heidelberg raytracing model, which illuminate
the object from the front and at an angle from above. In this way the surfaces of the object are also taken into account. If a surface is orientated towards a light source, it appears lighter than the other surfaces (diffuse reflection). In
addition, light from a different light source meets the virtual eye of the observer if it is mirrored on the surface (specular or directional reflection).
The light creates an improved 3D effect and fine outlines, but measuring faults are also more clearly visible. The
calculation of the light effect requires additional processing power from the graphics card.
If the performance of the graphics card is not sufficient to render a new 3D image within 2 s, Windows will stop the
graphics driver and then re-start it. In this case please select the smaller reconstruction size or a more powerful
graphics card.

Light Parameters (open with

)

The three components of the illumination (ambient, diffuse, specular) can be modified individually.

Effects → Stereoscopic View (red-cyan)
The stereoscopic view presents a very realistic 3D impression, by using a red (left eye) and cyan (right eye) filter in
anaglyph glasses. The filtering limits the colour rendering, so the most impressive view is achieved in black and white
- probably on a white background. Both parameters can be set in the colour spectrum.
Even in the stereoscopic view, individual pictures or a video can be exported. The format can be switched between
anaglyph and side-by-side (cross-eyed) in the AVI export settings.
Approximately 5 % of the population are unable to see the 3D impression using the stereoscopic view due to visual
limitations.

Effects → Full Screen
For a larger 3D display, the display can be spread over the entire screen. Then all of the control elements are no
longer available. However, rotation and zooming, and the effects in the context menu (right mouse button) are still
available.

© by LD DIDACTIC GmbH · Leyboldstrasse 1 · D-50354 Huerth · www.ld-didactic.com
Phone: +49-2233-604-0 · Fax: +49-2233-604-222 · E-mail: info@ld-didactic.de · Technical alterations reserved

16

Computed Tomography
The full screen can be left either via the context menu or by pressing any key.

3D Graphics Settings (open with

)

Depending on the graphics card used, the age of the driver and operating system used, it may be necessary to
change the graphics settings to achieve an optimum representation.
If several graphics cards are available in the computer system, the required 3D graphics card must be selected as
the adapter.
If the image is forming too slowly, the depth resolution can be reduced. Then not all the available voxels are shown
and some information is lost. A different option is to reduce the size of the reconstructions. However, after this the
reconstruction has to be recalculated (CT → Recalculate CT Scan).
For the calculation of the illumination, the normal vectors for each volume element are required. These can be calculated in advance by the CPU (main processor) or as required by the GPU (graphics processor). The calculation by
the GPU requires a lot less memory space on the graphics card, but usually it takes longer than reading out the normal vectors previously calculated by the CPU.
Many older graphics cards display the volume more rapidly if the volume texture is increased to an edge length of 2ⁿ
pixels. If one works with a resolution of the reconstruction of 256x256x256 or 512x512x512 this option does not make
any difference.
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Loading and saving of settings and 3D data
Project → Open
Loads an existing project with the settings and 3D data. The settings have the file extension *.ct. The automatically
loaded 3D data have the same name with the data extension *.ct3d.
After opening a project, the reconstruction process can be visualised by CT → Recalculate CT Scan or evaluated by
View → Show 3D View.
The production of various AVI exports is also possible.
A new project can only be created by CT → Start CT Scan.

Project → Save
Saves the current project properties (e.g. intensity, transparency, light parameters). The 3D data are not saved again.
New 3D data are automatically saved after the completion of the computed tomography together with the applicable
project properties.

Export as bitmap and AVI
Several options are available for export. For viewing or playing, an appropriate player is required, which is usually
started by double-clicking on the exported file.
The AVI export uses the AVI export settings.

Project → Save As Bitmap
Individual images can be directly saved as a bitmap during the setting of the camera or the 3D view.

Project → Export As → Projection Video
During the recording of a computed tomogram all the scanned projections are automatically saved in the subdirectory Projections\Project name. This collection of images contains the data the calculation of the computed tomogram is based on and it allows the production of a projection video which shows all the recorded projections during
one turn of the goniometer. In this way the data are available in a format easily understood by the human eye.
It is impressive how much detail can be observed during the repeated viewing of a projection video compared to a
single x-ray record. For more detailed evaluations, the computed tomogram calculated from this is more appropriate.

Project → Export As → Reconstruction Video xy, xz or zy
A completely calculated or loaded computed tomogram can be exported as a 2D film (in the xy, xz or zy planes). The
total information of the computed tomogram is contained in each of these videos.

Project → Export As → 3D Video
During the 3D view of a computed tomogram, an individual video clip can be generated which shows exactly those
images which have just been generated in the 3D view. It is not permitted to change the size of the window during the
creation of this video clips.
The length of the video clip is limited in the AVI export settings. However, it is possible to stop it earlier.
If the recording of a 3D video is switched on before the starting of a scan or a recalculation, the recording of the 3D
video is also restarted together with the scan or the recalculation. In this way videos can be exported which show the
3D back-projection process.
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Examples of experiments and instructions
Go to the step-by-step instructions

Simulation
In the installation CD the "Examples" sub-directory contains several recordings of computed tomograms. For space
reasons they are not automatically installed together with the program. If you would like to copy one of these computed tomograms to your hard disk, please remember that a complete computed tomogram comprises several files:




Projectname.ct contains the configuration
Projectname.ct3d contains the actual 3D data
Projections\Projectname is a directory where the recorded projections can be found. The projections are only required when the computed tomogram is to be recalculated.

These examples can be simulated by CT → Recalculate CT Scan without a computed tomography module and
displayed and evaluated in
or . Alternatively, the example can be displayed and evaluated after opening a project without recalculation.
On our Youtube Channel http://www.youtube.com/user/lddidactic, CT videos (some of which are stereoscopic) are
available. If you want to produce your own videos, the AVI export of the software is recommended. Then the videos
can, for example, be cut and titles added using Windows Movie Maker.

Own objects
There is plenty of scope for one's own experiments because naturally there are plenty of different potential objects to
be investigated. For the selection of the objects there are various criteria:







No living creatures
The radiation load in the X-ray apparatus is very high during a CT scan. Depending on the duration of the scan, it
can be associated with a radiation dose of over 1 Sv.
Only rigid bodies
The object to be investigated must be attached to the goniometer and during the scan it must be rotated once
around the goniometer axis. During this procedure its geometry must not changed, otherwise shadow images will
occur in the reconstruction.
No metals or very dense materials
The reconstruction algorithm assumes that for every point on the fluorescent screen the attenuation of the Xradiation can be calculated. However, if the attenuation is too high, clearly visible artefacts occur during the reconstruction because the projections of the fluorescent screen become inconsistent.
Only small objects
For a complete reconstruction, the objects must fit completely within the volume scanned. For the X-ray image
sensor the recorded volume is max. 4 x 4 x 4 cm³. The computed tomography module (554 821) offers a much
larger recordable volume of 8 x 8 x 8 cm³ at a considerably lower resolution.

A few promising examples for experiments are:






Plastic water cuvette for the determination of the attenuation coefficient µ water. This allows the computed tomogram to be calibrated for CT numbers. Please observe the setting options and the systematic errors.
Small freeze-dried dead creatures such as frogs can simply be mounted on an object carrier made from Lego (in
554 826) or can be packaged with cotton wool in a hollow polystyrene ball. Any irritating shadow from the cotton
wool in the computed tomogram can be hidden by restricting the colour spectrum. The various material densities
(bone, eyes, flesh) can be well distinguished.
Small plastic toys for children can be scanned easily with and without packaging and e.g. measured in any orientation and investigated for possible air bubbles.
Using the available optional computed tomography accessories (554 826) or the Lego adapter (554 825), small
Lego structures or Lego figures can be tomographed.
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Step-by-step instructions
Before recording a computed tomogram please check that the object to be investigated is suitable.
Independently of the actual object under investigation, the process for recording a computed tomogram is always the
same:

Preparation








Insert the W, Au, Ag or Mo (tungsten, gold, molybdenum or silver) X-ray tube into the X-ray apparatus.
Remove the collimator, sensor holder and the target holder from the X-ray apparatus.
Push the goniometer to the right-hand side and secure it.
Attach the object under investigation to the goniometer axis and close the doors. Preferably, the small objects are
stuck onto Lego plates (e.g. from 554 826) and attached to the Lego adapter (also from 554 826) on the goniometer. Alternatively, the expanded polystyrene ball with holder included in the computed tomography module can be
used.
Connect the devices to the PC and switch them on.
Start the computed tomography software.

Starting up the X-ray image sensor








The X-ray image sensor has to record dark images. This is apparent by the flashing of the red dot ( ) in the
camera settings. If not, check the connections and video device in the Camera settings.
Set the integration time in the Camera settings to 825 ms (for W and Au tubes) or to 1750 ms (for Mo and Ag
tubes).
If the black camera image shows irritating light spots, these can be suppressed by means of a defective pixel list
in the Camera settings. The same applies to individual, disruptive, dark spots when the X-ray radiation is switched
on.
The offset and flat-field corrections are also possible there in order to improve the quality of the computed tomogram. During the flat-field correction, the object to be investigated has to be removed briefly and the X-ray radiation has to be switched on.
Switch on the X-rays by clicking .
If the exposure display next to the upper, flashing, red dot ( ) indicates overexposure, either reduce the integration time by one step or reduce the anode current of the X-ray tube.
Carry out Image Adjustment and Calibration. The parameters set there are saved and will be available when the
program is started up again. If the adjustment of the image and the calibration have been successfully carried out
and the experimental setup has not been changed it does not need to be carried out again.

Starting up the computed tomography module









The camera in the computed tomography module must record dark images. This is apparent by the flashing of the
red dot ( ) in the camera settings. If not, check the connections, video device and video input in the Camera settings.
If light is entering the computed tomography module, check the alignment of the module and if necessary shift it
closer to the X-ray apparatus.
If the black camera image shows irritating light spots, these can be suppressed by means of a defective pixel list
in the Camera settings. Here a flat-field correction is also possible, although this is not normally necessary. To do
this the object to be investigated must briefly be removed and the X-rays switched on.
The camera images are averaged to reduce noise. In the Camera settings an averaging of 20 video frames for
every display image is the default setting. In this way every image recorded only requires just under a second. If a
Mo or Ag X-ray tube is used, increase the number of frames to be averaged because this tube produces considerably less X-radiation than the W or Au X-ray tube.
Switch on the X-rays by clicking .
Check the image brightness and the crispness. The aperture of the camera objective must be fully open and the
objective must be focussed on the luminous coating. The luminous coating is located behind the glass surface.
Carry out Image Adjustment and Calibration. The parameters set there are saved and will be available when the
program is started up again. If the adjustment of the image and the calibration have been successfully carried out
and the experimental setup has not been changed it does not need to be carried out again.

CT scan




Select the number and size of projections as well as the size of the reconstructions depending on the desired
quality and time to be expended. The projections should always be a little larger than the reconstructions. It is
recommended to start with fewer angles and smaller reconstructions. Only when you are sure that the camera
alignment is good can the settings be increased. This method saves a lot of measuring time.
Start the CT scan. The remaining scanning time is displayed in the upper right corner.
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2D view




If in the 2D view double outlines occur during the second half of the rotation, the rotational axis is not precisely
aligned. The doubled outlines can be prevented by means of a correction of the rotational axis in all of the planes
of the reconstructed volume. If a correction of the rotational axis is necessary, the CT scan should be repeated
with the modified camera adjustment.
If desired, the CT scan can be exported after recording as a projection video or reconstruction video.

3D view









In the 3D view, the reconstructed volume can be rotated or zoomed with the mouse.
For the display of the coordinates and the measuring of distances on the 2D cutting plane, it is recommended to
display only the cutting planes which can be modified by means of the large slide bar at the bottom.
The displayed colours result from a combination of the values set for intensity, transparency and the colour spectrum.
Automatic animations around the rotational axis or by means of the mouse are also useful for the production of
3D videos.
For better orientation, the limits of the computed tomogram can be marked by the edges of the cube.
Adding light helps to give a better three-dimensional impression. The light parameters can be adjusted.
The Stereoscopic View allows a true 3D presentation by utilising red-cyan spectacles (e.g. 55 827).
For displaying a larger 3D view, the display can be spread over the entire screen.
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Laue images using the X-ray image sensor
For the creation of Laue images, neither an activation code nor a powerful PC are required.

Preparation







Insert the W, Au, Ag or Mo (tungsten, gold, molybdenum or silver) X-ray tube into the X-ray apparatus. A W tube
or Au tube provides a better contrast than the much weaker Mo tube or Ag tube.
Insert pinhole collimator (in 554 8381) and fit crystal.
In order to make Laue images less affected by interferences, cover the centre of the X-ray image sensor by
means of a beam stop (in 554 8381).
Place the X-ray image sensor in front of the crystal at a distance of approx. 1.5 cm. The X-ray image is created
2 mm behind the carbon-fibre surface.
Connect the devices to the PC and switch them on. Allow the X-ray image sensor to warm up for approx.
5 minutes.
Start the computed tomography software.

Creating Laue images







The X-ray image sensor has to record dark images. This is apparent by the flashing of the red dot ( ) in the
camera settings. If not, check the connections and video device in the Camera settings.
Set the integration time in the Camera settings to 3500 ms.
Record the offset image. For this approx. 10 images have to be averaged before the offset can be completed.
Switch on the X-rays by clicking .
Record reference image. Once again, determine the average of approx. 10 images. While making this recording
of the reference image, the contrast can be readjusted by means of the reference image slider and the Laue image can be made visible.
If desired, the original image or a contrast-enhanced image can be saved with
for further processing. By saving
with a high greyscale resolution (16 bit), it is possible to produce good Laue images later from the original recording by means of suitable image processing software.
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