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Lab Docs Editor (200 320)
Lab Docs Editor 365 (200 323)
Lab Docs Viewer

1

Introduction

• Currently, Mobile-CASSY 2 WIFI (524 005W), Power
Analyser CASSY (727 100) and Power Analyser CASSY
Plus (727 110) are supported.

Lab Docs are editable HTML experiment manuals that can be
displayed in a platform-independent manner on any up to date
internet browser and that automatically adapt to the size of the
utilised device (smartphone, tablet, PC). No additional soft
ware is required to use Lab Docs.

However, even without CASSY, Lab Docs enrich digital learn
ing because measured values, images and experiment results
can also be manually recorded and evaluated by the student
in a Lab Doc.

Lab Docs are interactive:

Lab Docs can be edited with the Lab Docs Editor:

• Answers can be typed in and sketches or photographs
from observations can be added,
• Measured values can be entered in tables, wherein the
values are automatically transferred into diagrams,
• Diagrams can be evaluated directly in the document with
many fixed curve fittings and any number of free evalua
tions.
• The results can be stored in the browser and reloaded
again for later processing.

• Adapt all content to the respective lesson,
• Create new Lab Docs.
Many Lab Docs are available as a literature collection (e.g.
Science Lab Physics, Chemistry or Biology).

Lab Docs can connect directly with CASSY hardware:
• Simple connection of up to three terminal devices with
one CASSY by entering the PIN from the CASSY display,
• Automatic setting of the CASSYs, sensors and measure
ment ranges via the Lab Doc,
• Control of the CASSYs from the Lab Doc and
• Automatic transmission of the measured values from the
CASSYs into tables and diagrams in the Lab Doc.
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2 Technical Data
File format:

*.html, images and resources in separate
files
Exchange format: *.labdoc (all required files in one
container file)
Export format:
*.pdf (teacher and student version,
Internet access required for export)
Typesetting of
Optionally with LaTeX syntax (incl.
formulae:
mhchem package)
Lab Docs Visibility Teacher and Student Version
Settings:
Offline and Online Mode
Saving of student
data:
Locally on the student’s terminal device
Supported
MobileCASSY 2 WIFI (524 005W)
measured value Power Analyser CASSY (727 100)
server:
Power Analyser CASSY Plus (727 110)
Virtual
Multimeter, measurement data tables,
instruments:
diagrams, evaluations, vector diagrams*,
powermeter* and more than 10 more for
controlling the recording of measured
values
(*) only Power Analyser CASSY and
Power Analyser CASSY Plus
System
requirements for PC with Windows from Windows 7,
Lab Docs Editor: Internet access recommended
System
requirements for PC with Windows from Windows 7,
Lab Docs Viewer: private network or work network
System
Terminal devices with iOS, Android,
requirements for Windows, Linux or MacOS with WiFi
Lab Docs:
capability, local WiFi network (with or
without Internet access)

3 Lab Docs Visibility Settings
3.1 Teacher and student version and student data
Each Lab Doc contains a teacher and a student version. The
teacher version shows a model solution. When first opened,
the student version does not display any student answers or
measured values from the sample solution. Instead, the user
administration menu is shown in the top right of the header
line (see Fig. 1 top right).
The data entered by the student (student answers and mea
sured values) are stored in the browser until the browser tab
is closed. If the student logs in via user administration with
their chosen username and password, the data is stored in
the browser for 4 weeks. The data is encrypted, so only the
student can access it with their name and password combina
tion. This means they can continue to work on the Lab Doc on
the same tablet the next day, for example. If the student wants
to continue working on another terminal device, or if they want
to take a longer break, they must download the file with their
data via the user administration menu (*.labd file). The data
can be loaded again via the same menu. This also allows the
students to transfer their results to the teacher.
Notes: The student data from a *.labd file can only be loaded
back into an identical Lab Doc. If you have changed the
Lab Doc in the meantime, the student data can no longer be
displayed in it. The integrated user administration runs locally
in the browser and the content is not transmitted over the In
ternet.

In order that students do not have access to the teacher ver
sion, a Lab Doc normally displays the student version when it
is opened in an Internet browser. The teacher version can on
ly be opened via LeyLab, the Lab Docs Viewer or the Docu
ment Center (see Section 8).
3.2 Offline and Online Mode
If a Lab Doc can control a CASSY and display its measured
values live, elements to enable a connection with a CASSY
are displayed in the centre of the header line of the Lab Doc
(see Fig. 1). There are always two modes: Offline if a connec
tion to a CASSY does not currently exist, and online if a
CASSY is currently connected. In Offline mode, the teacher
version shows a sample solution and the student version
shows the last measured values of the student. Therefore, the
student version initially contains no measured values. In On
line mode, the current measured values of the CASSY are dis
played and the CASSY can be controlled.

Fig. 1:

A Lab Doc with virtual instruments can connect with a
CASSY and thus bring the virtual instruments to life. The
connection is established by clicking on Offline in the upper
illustration and entering the PIN for the CASSY that is to be
connected into the lower illustration.

4 Download and Activation
The Lab Docs Editor is only available as a download of the in
stallation package:
https://www.ld-didactic.de/software/labdocseditor.msi.
Before using the Lab Docs Editor, this must be activated via a
licence import. Otherwise no file operations such as loading,
saving, importing and exporting will be available. For the initial
activation, an unused product key for
• Lab Docs Editor (200 320, licence with unrestricted validi
ty) or
• Lab Docs Editor 365 (200 323, annual subscription li
cence)
is required. This product key must be activated via LeyLab (In
ternet access required).
All activated licences are managed in a LeyLab account. If
you already have a LeyLab account, please log in with your
login details before or during activation. You can view your li
cences in LeyLab under Licences→ My Licences and use
them on all of the school's or institution's terminal devices.
If neither you nor your school have a LeyLab account, a free
LeyLab account can be created during activation. Please use
the same LeyLab account for any licences you acquire in fu
ture.
The licence code created here must be either automatically
imported by the Lab Docs Editor from LeyLab (Internet access
required) or manually entered into the Lab Docs Editor (possi
ble without Internet access, see Fig. 2). You can find the li
cence import in Lab Docs Editor under View→ About ….
Important: You can only activate the product key once. When
re-installing the software, the software can import the activa
tion from your LeyLab account. But if you delete the LeyLab
account, you must manage the obtained licence code for new
installations yourself.
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Note: Keyboard shortcuts are also available for many of the
operation options via the tabs described in following text. The
shortcuts start with the Alt key and are displayed if you hold
down the Alt key for a longer period or release it without
pressing another key. For example, Alt+V denotes a variable.
6.1 File Formats and File Menu
*.html files

Fig. 2:

The file format of the Lab Docs and the Lab Docs Editor is
*.html (HTML5). Such HTML files can be displayed and con
trolled using all current Internet browsers (see Section 8).
Fundamentally, the content of such files can be edited using
any text editor. However, we recommend to exclusively use
the Lab Docs Editor. If an HTML file links to images or other
files, these automatically link in a subdirectory (img or res)
when saving with the Lab Docs Editor. Links to other Lab
Docs are also possible if these are in the same directory or in
subdirectories.

Activating the Lab Docs Editor.

Updates to the Lab Docs Editor are available for free from the
download link specified. If the Lab Docs Editor has an Internet
connection, information about updates is automatically dis
played when updates become available.

5

Lab Docs Editor and Lab Docs Viewer

During the installation, two links are automatically created in
the start menu: Lab Docs Editor and Lab Docs Viewer. Lab
Docs are edited using the Lab Docs Editor. Here, the
Lab Docs Editor displays the Lab Doc in an editor view that
differs from the format in which the Lab Doc is presented in an
Internet browser. The Lab Docs Viewer displays the Lab Doc
in the same format as in an Internet browser and offers some
additional functions (see Section 7).
The Lab Docs Editor always also launches the Lab Docs
Viewer, because this shows the final appearance of the
Lab Doc and can also switch between the teacher and student
version of a Lab Doc. Its window can, for example, be moved
to a second monitor or separately resized to test how the
Lab Doc would look on the narrow display of a smartphone.
The Lab Docs Viewer can also be launched on its own in or
der to view a Lab Doc or to distribute it in the local network,
e.g. to a school class wherein the students cannot access the
Internet (see Section 8).

6

Using the Lab Docs Editor

The Lab Docs Editor is used in a similar manner to other text
editors, but has one fundamental difference: content and lay
out are strictly separated. You can only edit content ‒ the lay
out is automatically created.
Therefore, in all cases, only the contextual meaning and not
the appearance is specified. Only values such as information,
variables and titles are set, whereas stylistic information such
as bold, italics or font size is not. For you as the author, this
offers the advantage that you no longer have to be concerned
about the layout if you have allocated the right values to the
text passages.
The actual layout is specified and is the same as LD DIDAC
TIC GmbH's student experiment manuals. If you change exist
ing student experiment manuals, the LD logo and the copy
right information will be replaced by your logo and your copy
right information. The administrator of your LeyLab account
can set your logo in LeyLab under Settings→ School.

*.labdoc files for exchange
The HTML file is only conditionally suitable for exchange with
colleagues, for example, because the linked files and images
are also required. For this, we recommend the *.labdoc export
under File→ Export. This creates a *.labdoc file that contains
all files required for the Lab Doc. This *.labdoc file is also used
to add a Lab Doc to an experiment created in LeyLab (see
Section 8).
*.pdf files for printing
A Lab Doc can be exported as a PDF file for printing the in
structions. Exported PDF files have a printing layout that is
adapted to the paper size and are no longer interactive.
If you add a Lab Doc to one of your experiments in LeyLab,
the associated PDF files are also automatically offered there
for the teacher and student version. Alternatively, you can also
export a PDF of the teacher version or the student version di
rectly in Lab Docs Editor under File → Export. To do this you
will need an Internet connection because the PDF export is
performed by LeyLab.
If the Lab Doc contains chapter headings (Heading 1) with
specific keywords, additional page breaks are inserted that di
vide the document into several parts:
Part of the
document

Chapter heading starts with...

Instructions

Introduction
Additional break only if Introduction is
not the first visible heading.

Worksheet

Observation
To be printed out and copied for each
student. It always starts on the righthand page and a name field is
automatically added.

Appendix

Appendix or Risk assessment

This action is controlled by the option Optimise work sheet
for printing. This option guarantees that student worksheets
automatically have a name field and can be printed in a man
ner that saves paper wherever possible. If the entire docu
ment is to be printed on the fewest possible pages, however,
Optimise work sheet for printing can be switched off. This
affects both the PDF export of Lab Docs Editor and the auto
matic PDF generation of *.labdoc files imported into LeyLab.

© by LD DIDACTIC GmbH · Leyboldstraße 1 · D-50354 Hürth · www.ld-didactic.com
Tel: +49-2233-604-0 · Fax: +49-2233-604-222 · Email: info@ld-didactic.de · Technical alterations reserved

4 / 10

Instruction sheet 200 320

Document Properties
The properties of the current document can also be set in the
file menu. In particular, these include the title and the lan
guage of the Lab Doc. A number is prefixed to the title that en
ables the experiment to be assigned to categories with sever
al breakdown levels. Each point in the number denotes a fur
ther level. The titles of the categories used can be specified
under the title entry and are displayed in the header of the Lab
Doc under the title.
The set language determines the language on non-editable
displays in the document (e.g. in the numbering of image cap
tions) and the language profile of the voice that can be
switched on in the browser to read the Lab Doc aloud. The
read-aloud function is not supported by Lab Docs Viewer and
Internet Explorer.
6.2 Start Tab

Fig. 3:

The Start tab contains all contextual meanings and visibility
settings.

Paragraph Format Group
The paragraph types define the contextual meaning of sepa
rate paragraphs that lie between paragraph marks (set with
the Enter key). The start and end of a paragraph can be iden
tified by the coloured bands on the left-hand side of the text.
Paragraph types are available for normal text, 3 heading lev
els and bulleted as well numbered lists.
The contextual meaning of the current paragraph can be
recognised both by the highlighted item in the tab group Para
graph format and also on the left in the footer of the editor.
Text Format Group

solution in the teacher version. If entire images are highlighted
as a student answer, the students are given the option of inte
grating their own images in the student version.
Links
The Link text format allows web pages or other documents
(*.html or *.pdf) that are opened by clicking on the link to be
linked to in a Lab Doc. Linked documents must be saved in
the same directory as the Lab Doc or in a subdirectory.
Formulas Group
On the one hand, formulas can be entered using the text for
mats Variable, Superscript, Subscript and Break, e.g. s =
1 2
a·t . On the other hand, they can be set using LaTeX syn
2
tax, e.g. with the LaTeX text format, s = \frac{1}{2}\, a\cdot t^2
becomes:
.
Various special characters are available to be entered as nor
mal text via Insert→ Special character. It is easiest for the
Variable text format to be subsequently applied to a formula:
Highlight the entire formula and activate Variable. Each letter
sequence is automatically highlighted as a variable with con
sideration of arithmetic operators, numbers and indices. The
Break text format recognises a colon as a separator between
1
numerators and denominators. Hence 1:2 simply becomes .
2
The LaTeX formatting uses the MathJax package with the
mhchem expansion. Since the font differs between the direct
formulas and the MathJax package and the loading time of a
Lab Doc is slightly increased by MathJax, we only recommend
the use of MathJax for complex formulas or for formulas that
require formula numbering. Formula numbering is active as
standard for all LaTeX formulas that occupy an entire para
graph:

Both an entire paragraph and a part of a paragraph can have
additional meanings. For example, the text can be defined as
an instruction or as a variable in a student answer.
To apply such a text format to an entire paragraph, first high
light the paragraph by clicking on the coloured band on the left
or highlight the entire text of the paragraph and then select the
desired text format. The active text formats can be identified
by the colours of the band on the left, by the tooltip when hov
ering the mouse over the band and by the highlighted items in
the Text format tab group.
There are several options for applying a text format to part of
a paragraph:
• Highlight the text and then select the desired text format.
• First select the desired text format, type the text that is to
be formatted and then switch off the text format again.
• If the cursor is placed within a word, a text format is auto
matically applied to the entire word.
The active text formats can be identified by the colour of the
text, by the tool tip when hovering the mouse over the text and
by the highlighted items in the Text format tab group.
Note: For example, some text formats cannot be applied to
entire paragraphs and vice versa. It is not logical to set an en
tire paragraph as superscript or to apply a safety instruction to
just one part of a paragraph.

Automatic numbering can be individually deactivated by
switching off Number equation (right mouse button). You can
easily find further information and online formula editors for
LaTeX on the Internet.
Visibility Group
The Teacher's version and students' version visibility
modes restrict the visibility of text but do not change the func
tionality of the text (unlike Student answer). This means that
it can be used to add text (or images) that only the students or
only the teacher should be able to see (student or teacher ver
sion, see Section 3.1).
The Online mode or Offline mode visibility modes behave in
a similar manner in Lab Docs that can connect with a CASSY
(see Section 3.2). Online mode text is then only visible when
a connection to a CASSY exists or is established. Offline
mode text is then only visible when the Online mode text is
not visible. It is only relatively rare that it is necessary to ex
plicitly set these visibility restrictions yourself, because the vir
tual instruments (see Section 6.4) already provide expedient
offline annotation.

Student Answers
Paragraphs or parts of paragraphs that are highlighted as stu
dent answers are displayed as an input field in the student
version. The text visible in the editor is displayed as a sample
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6.3 Insert Tab

Fig. 4:

Attached Files

A Lab Doc can be expanded with images, simple tables,
symbols and links to attached files in the Insert tab.

Paragraph
A new paragraph can be inserted underneath the current posi
tion using Paragraph. This is also possible in the text using
the Enter key. Using this button, a paragraph can also be in
serted after an illustration or a table.
Images
Images can be easily inserted with Image. Here, an image
caption appears automatically. This can also be removed by
deselecting Display caption (right mouse button). In addition,
the size of the image can be changed and the image file can
be replaced using the right mouse button. Furthermore, addi
tional images for the same figure can be added so that they
have a common image caption.
Upon saving the Lab Doc, the inserted image files are stored
in the img subdirectory of the Lab Doc. Here, large *.jpg files
are reduced to an expedient size.
Small images can also be inserted as symbols in tables or in
body text (see below).
Tables
Tables can be inserted via Table. They can have a header line
and/or a header column at the top and/or left (right mouse but
ton). The context menu (right mouse button) also permits vari
ous other manipulation options for the table. In addition, indi
vidual table cells can be highlighted as Student answer so
that the students can make an entry at this point.
If a table should also contain measured values, the virtual in
strument Measurement data table is more suitable (see Sec
tion 6.4) because these values can then be shown in a dia
gram or taken into consideration in an evaluation.
Material Tables
The material table is a special table with special functionality.
It is intended for devices, chemicals and additionally-required
materials. Clicking on the item name displays an image of the
item, provided that an Internet connection exists and an image
is available. Furthermore, links to the Web Shop are automati
cally created in the teacher version.
The creation of material tables is easier if an Internet connec
tion exists. To automatically receive a name suggestion for the
item as well as any hazard symbols, you only need to enter
the LD catalogue number.
Additional options are available via the right mouse button in
the Catalogue number and Info columns. With these, you
can assign attributes to catalogue numbers or specify whether
the material is only required for each class (e.g. scales) or
even for each student (e.g. safety glasses).
Icons
Small images can be inserted directly into the text as symbols
here. A range of icons (e.g. safety icons) are available under
Provided icons. Custom icon permits any image to be in
serted as an icon.

This function allows additional files, to which a Lab Doc
should refer, to be attached. If you click on the file name in the
text of a Lab Doc, the file is downloaded and can then be
opened on the terminal device. These files are stored by the
editor in the res subdirectory. This is expedient for providing
files for measurement and evaluation with other programs or
linking *.labm files with CASSY settings that the student can
use to set up a CASSY via USB if there is no direct connec
tion between Lab Doc and CASSY (offline mode).
If you would like to link to other documents or web pages, use
Link in the Start tab.
Special Characters
Here, the Lab Docs Editor offers the option of easily inserting
special characters (e.g. Greek letters).
6.4 Virtual Instruments Tab

Fig. 5:

The Virtual instruments tab shows interactive elements for
displaying and controlling measurements.

Virtual instruments enable a large degree of interactivity in a
Lab Doc. They are interactive elements for displaying and en
tering measured values and controlling measurements. Each
virtual instrument is linked with a so-called measurement se
ries that has a unique name and contains the definition of the
measured variables and their measured values. Therefore, all
virtual instruments for a measurement series draw upon the
same measured values. The virtual instruments in the group
With CASSY (see Fig. 5) are only expedient with Lab Docs
that establish a connection with a CASSY.
Measurement Series
Measurement series are the basic prerequisite for being able
to display virtual instruments. When creating a virtual instru
ment, this can be linked with an existing measurement series
or a new measurement series can be created. If no measure
ment series have yet been defined, this takes place compul
sorily when a virtual instrument, measurement data table, dia
gram, multimeter, vectorscope or powermeter is created.
There are two types of measurement series:
• Measurement series with CASSY (green background)
enables the connection to a CASSY. This measurement
series is created by importing a *.labm file. Carry out the
measurement with the CASSY, store the measured val
ues as a *.labm file and transfer the file to the PC using
the Lab Docs Editor. The Editor takes over all settings of
the experiment, the list of utilised measured variables and
the measured values that are displayed as the sample
solution in the teacher version from the *.labm file.
Note: The CASSY saves a *.labm file via the menu item
→ Save values → *.labm.
The virtual instruments, multimeter, vectorscope or pow
ermeter require a measurement series with CASSY as
mandatory. If a measurement series with CASSY be
comes active when loading a Lab Doc for the first time,
the associated settings such as measured variables,
measurement ranges and measurement interval are au
tomatically transmitted to the CASSY.
• Measurement series without CASSY (brown back
ground) only contains measured values by typing into
measurement data tables in the Lab Doc (see below).
This measurement series is created by specifying the
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number of measured variables. All designations of mea
sured variables, units, measurement ranges and mea
sured values for the sample solution must be manually
entered by the author.
Measurement series are not directly visible in the document
via the virtual instruments but are indirectly visible, e.g. via a
measurement data table. You can select View→ Measure
ment series to get an overview of the available measurement
series. Any number of diagrams and measurement data ta
bles can access a measurement series and display or change
its measured values within a Lab Doc.

Fig. 6:

If several measurement series are used in a Lab Doc, when a
new measurement series is first used, the virtual instruments
switch over to this. In doing so, the respective settings are al
so transferred to the CASSY. You can recognise which mea
surement series is currently active from the number after the #
in the header line of the Lab Doc.

Diagram

Measurement data table
If no measurement series had yet been created when compil
ing a measurement data table, such as with the first virtual in
strument, then firstly the first measurement series is created
(with or without CASSY, see above). If a measurement series
had already been created, this can be selected as an alterna
tive. After this, the measurement data table belongs firmly to
this measurement series. When compiling the table, the mea
sured variables that are to be displayed can be preselected.
This selection can still be changed later as desired.
The content of the table can be directly edited in Lab Docs
Editor. In the editor view, the table has three header lines for
name, symbol and unit of the measured variables. In Lab Doc
these are consolidated in a formatted header line. The body
section contains the values of the sample solution. Since sev
eral measurement data tables display the same data for the
same measurement series, all changes in the editor have an
immediate effect on all of these measurement data tables in
the document.
In the case of a Measurement series with CASSY (green
background), the table already knows most properties of the
measured variables such as symbol, unit, measurement range
and number of significant decimal places. These can also no
longer be changed, to ensure that the values correspond with
the CASSY display. It is only the name of the measured vari
able that is not a component of the *.labm file and which has
to be manually entered into the first line of the table.
In the case of a Measurement series without CASSY (brown
background), all of these properties and values must be man
ually defined. This is affected directly in the table. The mea
surement ranges (display ranges for a diagram) and the num
ber of significant decimal places of the measured variables
are specified in the properties of the respective Measured
variable (right mouse button on the column).
The Table settings can also be accessed via the right mouse
button. Here, for example, it is possible to switch off the stan
dard behaviour, wherein a measurement data table automati
cally extends if more measured values are entered than the
minimum length of the table (also configurable).
You can always add additional measured variables without
CASSY to a measurement series with CASSY, wherein these
must then also be defined purely manually. This is affected ei
ther in the settings of the Measurement series (right mouse
button of the table) or via the Insert column on the right→
Add measured variable (without CASSY). Here, you can al
so alternatively add pure text columns that are independent of
the measurement series and therefore cannot also be dis
played in a diagram or another table.

Measurement data table with 3 header lines with the defini
tion of the measured variable and the measured values. The
right column originates from a measurement series with
CASSY. The left column is a subsequently defined mea
sured variable without CASSY in the same measurement
series.

If no measurement series had been created when creating a
diagram, such as with the first virtual instrument, then the first
measurement series is first created (with or without CASSY,
see above). If a measurement series had already been creat
ed, this can be selected as an alternative. The diagram then
firmly belongs to the selected measurement series. When
compiling the diagram, the measured variables that are to be
displayed can be preselected. This selection can still be
changed later as desired.
In the case of a Measurement series with CASSY (green
background), no measurement data table is required to com
pletely define the diagram because the settings are already
contained in the measurement series.
In the case of a Measurement series without CASSY (brown
background), a measurement data table is vital in order to de
fine the measured variables and the values of the sample so
lution and to give the students a table in which they can enter
the measured values that are then to appear in the diagram.
In Settings ( or right click on the diagram), the suggested ti
tle, the axis assignment, the axis ranges and the appearance
of the diagram can be changed. Additionally, curves with fur
ther measured variables can be added later and their order
(colours) can be changed.
The instruments Evaluation, Zoom axes and Marker can be
used to modify a diagram interactively. Therefore, the buttons
to insert these instruments can be found via the arrow next to
the Diagram button.
Evaluations
Evaluations are linked to a specific measured variable of a
specific diagram in the Lab Doc and are also shown in this di
agram. A button to switch the evaluation on and off appears in
the place at which the virtual instrument Evaluation is insert
ed in the body text. If it is switched on, the results of the evalu
ation are also displayed there and, in the case of free evalua
tion, the evaluation is controlled. The virtual instrument Evalu
ation can also contain several different evaluations. In this
case, the user can later select one of the evaluations. There
are two types of evaluations:
• Default evaluations are automatically carried out during
selection and the result is displayed. A limited selection of
evaluations are available such as average value or bal
ance line.
• Free evaluations are set manually via sliders. Any mathe
matical functions are possible here.
The button for inserting an evaluation can be found via the ar
row next to the Diagram button.
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When creating an evaluation, its settings open automatically
and these can be accessed again later at any time via their
context menu (right click). Here, right at the top, the diagram
and the measured variable that are to be evaluated are select
ed. These can be changed at any time. Among these, any
number of default evaluations and one free evaluation can be
activated. Under all active evaluations, the user must later se
lect an evaluation that they want to carry out. If multiple evalu
ations are to be active at the same time, several separate
Evaluation virtual instruments must be added to the docu
ment.
If the predefined evaluation contains parameters, the symbols
of the parameters below the list can be adapted to the names
of the respective Lab Docs. This is not possible if there are
multiple evaluations to choose from, because their parameters
most likely have different meanings. For specified evaluations,
the units are automatically determined from the units of the
measured variables.
Further settings are required for the free evaluation:
• The name of the evaluation that is displayed in the
Lab Doc.
• The formula of the evaluation that is displayed in the
Lab Doc. Here, variables should be written so as to be
enclosed with $, set as superscript with ^ and set as sub
script with _. If this is not sufficient, the complete HTML
syntax with <var>, <sub> and <sup> can also be used.
• The formula as JavaScript is the JavaScript source
code that is executed to calculate the evaluation in the di
agram. Questions about the notation are answered in the
help text that is concealed behind the ? button.
• Symbol, Unit, Range and Step with configure the slid
ers for each parameter of the formula. The corresponding
lines appear automatically when a parameter is entered
in the formula in JavaScript.
The sample solution can be transferred from the Lab Docs
Viewer so that an evaluation that is suitable for example mea
sured values is displayed in the teacher version. To do this,
the settings of the evaluation must be opened, then the evalu
ation must be activated in Lab Docs Viewer and (in the case
of the free evaluation) optimised, and then Take over from
preview must be clicked in the open settings window.
Zooming the axes
This instrument is a slider for zooming in the measured vari
ables in a diagram.
When inserting this instrument, the settings open automatical
ly and can be accessed later at any time via its context menu
(right click). At the very top, the diagram and the measure
ment type to be zoomed are selected. These can be changed
at any time. Underneath, a slider can be enabled for the upper
and lower range limits of the axis of the measurement type. If
the Symbol field is filled, it is displayed to the left of the slider.
Symbols with subscript can be achieved by entering _ and su
perscript by entering ^.
Marker

same direction) and points (one horizontal and one vertical
marker) can be read. If the Symbol field is filled, it is dis
played in the Lab Doc to the left of the slider. Symbols with
subscript characters are possible by entering _ , superscript
characters via ^.
If more than two markers are needed, multiple marker instru
ments can be inserted.
Setting parameters
This instrument consists of a slider and text field for entering a
single measured value of a measurement variable - like a
measurement table consisting of only one cell. This is particu
larly useful as a parameter of a calculated measurement type
(see below, in the section Calculator).
When creating this instrument, it is assigned to a measure
ment series and then to a measurement type of this measure
ment series. The slider then sets the first measured value of
this measurement type. Measurement series, measurement
type and measurement value number can be changed later at
any time in the Settings (context menu).
Multimeter
This virtual instrument displays the current measured value of
a measurement variable of the connected CASSY in real time.
It is therefore only useful when connected to a CASSY and
can only be linked to Measurement series with CASSY
(green background). The measurement type to be displayed is
selected when creating the multimeter and can be changed
later at any time in the Settings (right click).
Alternatively, the multimeter can always display the current
measured value of the currently active measurement series.
Then the instrument remains active even when switching be
tween measurement series. To do this, select the Always
switch to the active measurement series option when cre
ating the multimeter. In the Settings of the multimeter (right
click) you must then specify the number of measurement
types to be displayed from which input of the CASSY, because
the name and meaning of the measurement type may change
when switching to another measurement series (and thus the
settings of the CASSY).
In Offline mode, it shows in the student version no value and
in the teacher version the last measured value of the mea
surement series as standard. In Settings (right click), the title
of the virtual instrument and the value displayed in offline
mode can be changed.
Vectorscope, Powermeter
The vector display and the power meter are only available
when using the Power Analyser CASSY (727 100) or the Pow
er Analyser CASSY Plus (727 110) and can be found under
the menu item Power Analyser CASSY. This virtual instru
ment is similar to the multimeter, but displays the current mea
sured values of several fixed measurement types. Apart from
that the settings correspond to those of the multimeter.
Virtual Instruments for Controlling the CASSY

This instrument is a slider for placing markers on a curve in di
agrams. That makes is possible to read individual measure
ment values or intervals (by using two markers) from one dia
gram.
The settings open automatically when inserting this instrument
and afterwards they can always be accessed via the context
menu (right click). At the very top, the diagram and curve to
be marked can be selected. These can be changed at any
time. Below that one or two markers can be activated, which
can be moved horizontally or vertically with the corresponding
slider. With two markers, both intervals (two markers in the

All virtual instruments for controlling the CASSY require a
measurement series that has already been created by one of
the aforementioned virtual instruments. They are inserted as
buttons directly into the text of a Lab Doc.
After the virtual instrument has been created, its Settings can
be changed via the right mouse button.
If several students are connected to the same CASSY, only
one student may operate the virtual instruments.
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measurement variable is removed from the calculator, it re
mains in the original measurement series.

Function
Start / stop measurement

Slider for the frequency or amplitude of the
Hearing Threshold Adaptor

In addition to these references to other measurement series, a
calculator can also contain its own measured variables: In
particular, New formulas can be added using the buttons be
low the list Measurement variables of this calculator. If you
mark a formula in the list of measurement variables, the for
mula can be edited in the area below the list. In particular, the
formula that is used to calculate the measured values is speci
fied here as JavaScript source code. In the formula, the mea
sured values of all other measurement variables of the calcu
lator can be used. The easiest way to do this is to drag a mea
surement variable from the list into the formula while holding
down the left mouse button. The measurement variables are
written in the formula as a[i], where i is the index of the mea
surement variable in the list. These designations are also
shown on the left-hand side of the list.

The measured variable is multiplied by a factor
that the user enters into the Lab Doc.

Note: If the list of measured variables of a calculator changes,
the designations a[i] in the formulas must be adapted.

Delete last measured value
Delete all measured values
Tare the measured value for measured variables
that also support this in CASSY
Manually switch on / off measured variable
Manually switch measuring range

The offset that the user enters into the Lab Doc
is added to the measured variable.
First value of a two-point calibration that
determines a factor and an offset. If no second
calibration point is defined, only the offset is
determined.

Further questions about the syntax of the formulas are an
swered by the help text which can be found behind the ? but
ton.
6.5 View Tab

Second value of a two-point calibration that
determines a factor and an offset, if no first
calibration point is defined, only the factor is
determined.
Deletes the calibration in the connected CASSY.
Fig. 7:

Calculator: Combining measurement series and
calculated measurement variables
A calculator is a special type of measurement series that adds
two functions to Lab Docs:
• Via a calculator, measured variables of different measure
ment series can be displayed together in a measurement
data table or a diagram.
• Calculated measured variables can be created in a calcu
lator, the measured values of which the Lab Doc auto
matically determines using any formulas from other mea
sured variables. These measurement variables, called
formulas, can be displayed in measured data tables and
diagrams.
Measured data tables and diagrams can be linked to a calcu
lator instead of an ordinary measurement series when creat
ing them. A new calculator is created via New measurement
series. Here a calculator can be created instead of a mea
surement series with CASSY or without CASSY. This opens a
window with the calculator settings, which can be opened later
at any time via View → Measurement series or a virtual in
strument linked to the calculator.
The settings window of a calculator shows a list of all Mea
sured variables of this calculator in the centre, which is ini
tially empty. From the list above, any measurement variables
of other measurement series can be added to the calculator
by dragging them into the lower list while holding down the left
mouse button. This way you can add measurement variables
from different measurement series. Measured data tables and
diagrams which are linked to the calculator can then display
these measured variables together. The measurement vari
ables remain in their original measurement series. The calcu
lator only refers to them - recognisable by the name of the
original measurement series in the lower list. Changes to the
properties or measured values of these measurement vari
ables also affect the original measurement series. If such a

The preview can be controlled and various menus opened
via the View tab.

Preview
Opens the Lab Docs viewer if it has been closed in the mean
time or switches it to the current document and brings it into
the foreground.
Help
Opens these instructions for use in the Lab Docs Viewer. A
second click switches back to the preview.
Validator
The validator helps you to create an appealing and well-func
tioning Lab Doc. It checks the Lab Doc and indicates content
that should not be used in this way. The messages are divided
into faults and warnings. When the message is clicked, the af
fected paragraph is highlighted in the editor view, insofar as
an assignment is possible.
The validator checks the saved file. The messages are there
fore only updated when the Lab Doc is saved.
Comments
A Lab Doc can be provided with comments in the Lab Docs
Editor that can help the author when processing the Lab Doc.
Comments are not visible in the Lab Doc (Lab Docs Viewer,
Internet browser), but they are visible in the source text of the
HTML file.
A comment always relates to one or more paragraphs or to
text within a paragraph. A new comment can be set for the se
lected text or paragraph via the tab Start, group Edit – such
as a text format (see Section 6.2).
If you select a comment in the list, the associated text or para
graph is highlighted in the editor view. Furthermore, the com
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ment can be subsequently changed or deleted there. Re
sponses to comments simplify the joint creation of a Lab Doc
with several persons.
Search and Replace
The search function searches through the text of the Lab Doc
and can also be launched using Ctrl+F. You can click on the
individual hits in the list. You can go to the next hit by clicking
on search again or by pressing the Ctrl+F, Enter or F3 keys.
Measurement Series
An overview of the measurement series of the Lab Doc is
shown here (see Section 6.4). The settings of each measure
ment series can be opened via the list; these are alternatively
also available via each virtual instrument that is linked with the
measurement series.
About…
Shows the version information and the licence status of the
Lab Docs Editor.

7

Using the Lab Docs Viewer

When the Lab Docs Viewer is launched with the Lab Docs Ed
itor, it shows the current Lab Doc of the Editor and thus en
ables an automatically updated preview. Furthermore, the
Viewer offers other advantages in comparison with a normal
Internet browser:
• You can switch between the teacher and student version
of the same Lab Doc at any time via the buttons
Teacher's version and Students' version.
• Instead of the preview, the Viewer can also display a QR
code of the current Lab Doc, which enables this Lab Doc
to be used easily on other devices in the local network as
long as the Lab Docs Viewer is running. This means that
when processing with the Editor, the Lab Doc can, for ex
ample, be quickly tried out on a smartphone or distributed
to an entire class in a lesson from the teacher’s PC (see
Section 8).
If the Lab Docs Viewer has been launched directly via the
Start menu and not via the Editor, a Lab Doc can be opened
via or via drag & drop.

8

Distributing Lab Docs

A Lab Doc must be distributed to all student devices so that
students can experiment using the Lab Doc on their terminal
devices. Since Lab Docs are Web pages, it is reasonable that
they should not be copied onto all student devices, but rather
that a web server should be used that makes the Lab Doc ac
cessible to all devices via a local network or via the Internet.
The students merely have to enter the address of the Lab Doc
on the web server in the Internet browser. This is even easier
if the address is coded as a QR code. Mobile terminal devices
can scan these codes with their cameras and can then open
the web page (the Lab Doc) automatically.
In principle, Lab Docs can be distributed via any web server.
We offer three solutions that are described below. All three al
so allow easy access to the teacher version of the Lab Doc.
8.1 LeyLab
A web server that can be reached via the Internet is neces
sary if the student is also to be able to access the Lab Doc
from home. This can be the school's own server or LeyLab.

LeyLab gives you access to all Lab Docs in the literature
package purchased and allows these to be distributed to stu
dents via a temporary link. After activating the purchased liter
ature package, you can find these in LeyLab under LD Exper
iments. Open the desired experiment. Teacher and student
versions of the associated Lab Doc are listed as two separate
documents in the Documents tab. With the student version,
click on Share and copy the link or the QR code for the stu
dents. Please note that you will only be able to share time-lim
ited document links with your students.
Even the free access to LeyLab also offers the option of creat
ing your own experiments and uploading and distributing your
own Lab Docs. These Lab Docs must be exported from the
Editor as *.labdoc files and added to one of your own experi
ments in LeyLab. To do this, create an experiment in LeyLab
under My Experiments and click on Edit at the top. You can
then upload a Lab Doc in the Documents tab. After clicking
on Save, the student version can be distributed in exactly the
same way as an LD document.
Note: For licensing reasons, it is not permitted to grant the students
their own access to LeyLab or to share teacher access with
students. You must also ensure that you own the rights to the
distributed documents. This is, however, the case with the
documents from the literature package purchased from LD DI
DACTIC, even if you have changed the files.
URL: https://www.leylab.de
8.2 Lab Docs Viewer
If a PC with Lab Docs Editor installed is available, the
Lab Docs Viewer can be used to distribute your own
Lab Docs. Launch the Lab Docs Viewer via the Start menu
and move the HTML file into the Viewer via drag & drop. En
sure that the Student view is selected in the menu bar at the
top. The students can use the QR code displayed to open the
Lab Doc (QR code button in the menu bar).
The Lab Docs Viewer distributes the HTML file via the local
network (private network or workplace network, not public net
work). No Internet access is required for this. However, this al
so has the disadvantage that students can only open the Lab
Doc within the local network, i.e. not from home.
Firewall
During installation of the Lab Docs Editor, the Windows fire
wall was configured in such a way that the distribution of
Lab Docs in the local network only functions if this network is
a private network or a workplace network. If it is a public net
work, the distribution of Lab Docs only works within your com
puter ‒ but not to another terminal device on the same net
work. If you use another firewall, you may have to configure
this yourself.
8.3 Document Center
If you have activated a purchased literature package in Ley
Lab, this literature licence can also be imported into the Docu
ment Center Software on a PC. After this, the literature will al
so available on this PC without permanent Internet access
and you can distribute the individual Lab Docs to students in
the local network via a QR code (QR code button in the menu
bar, private network or workplace network, not public network)
from the PC. You can switch between the student and teacher
version of the Lab Doc via the button Show information for
teachers.
Your own Lab Docs can also be distributed via the Document
Center (from version 1.14 onwards). To do this, a directory for
your own Lab Docs can be specified in the Document Center.
Each Lab Doc within this directory can be displayed by the
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Document Center and can also be distributed to the class via
the QR code.
Download: https://www.ld-didactic.de/dc

9 Examples
The following examples show how the various functions of the
Lab Docs are created with the Lab Docs Editor. To familiarise
yourself with the Lab Docs Editor, open the examples one af
ter the other directly in the Lab Docs Editor. They can be
found directly on the Start page or under File → Open → Ex
amples. You can then reproduce the described functions di
rectly in the Editor view and in the preview and can then try to
replicate these in your own Lab Doc.

9.4 Example 4: Two measurement series with CASSY
In this example, a Lab Doc is created that establishes a con
nection to a Mobile CASSY 2 and contains two measurement
series for two separate parts of the experiment with different
settings for the Mobile CASSY 2. The currently active mea
surement series is indicated by the number behind the # in the
title bar of the Lab Doc. Various options are shown for switch
ing the active measurement series.
9.5 Example 5: Calculated measured variables
In this example measured variables are calculated via formu
las from measured values and parameters and are displayed
in tables and diagrams.
9.6 Other examples

9.1 Example 1: Visibility and formulas
In this example, text is given different values so that it is only
visible in the teacher version of the Lab Doc or it is formatted
as a mathematical formula, for example.

Many Lab Docs are available as a literature package (e.g.
Physics, Chemistry or Biology Science Lab). If their product
keys have been activated in LeyLab, the examples can be
viewed there and also downloaded as a *.labdoc file and
processed with the Editor.

9.2 Example 2: Measurement series without CASSY
In this example, a measurement data table is created that is
populated by entering measured values and a diagram that
automatically displays these measured values.
9.3 Example 3: Measurement series with CASSY
In this example, a Lab Doc is created that establishes a con
nection to a Mobile CASSY 2 and transmits settings for volt
age and current measurement to the Mobile CASSY 2. A mul
timeter is created that displays the measured voltage of the
Mobile CASSY 2 in real time. Furthermore, a button is added
to record measured values as well as a table and a diagram
that display the recorded values.

10 Software libraries used
Lab Docs Editor and Lab Docs Viewer use the following open
source software, that is covered by the MIT licence:
• CommandLineParser © 2019 gsscoder, nemec, ericnew
ton76.
• ControlzEx © 2019 Jan Karger, Bastian Schmidt, James
Willock.
• Fluent.Ribbon © 2018 batzen.
• Gu.Wpf.NumericInput © 2017 Johan Larsson.
• HtmlAgilityPack © 2019 ZZZ Projects, Simon Mourrier,
Jeff Klawiter, Stephan Grell.
• Newtonsoft.Json © 2019 James Newton-King.
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